¿Porqué WordPress pide confirmar ftp para actualizar o instalar un pluging?

por | noviembre 2, 2014

Solución para cuando WordPress te pide los datos de acceso FTP cuando vas a instalar y actualizar plugins o temas.

Cuando encuentras al “admin” de tu WordPress se te piden tu usuario y una contraseña. Al entrar,  se le está dando a Wordpress la capacidad  de acceder directamente a los ficheros del alojamiento a través de la configuración de permisos, pero a veces el servidor (hosting) está configurado con opciones más restrictivas. Lo normal es que los plugins se instalen automáticamente sin necesidad de introducir los datos del FTP, esto hace de WordPress un sistema muy cómodo y rápido de manejar para cualquier usuario no experto.

El echo de tener que introducir tus datos de FTP cada vez que quieras instalar o actualizar un plugin, no sólo es incómodo sino que es un fallo de seguridad si usas un ordenador compartido ya que el navegador almacena las contraseñas.

¿Cómo evitar introducir el FTP en cada actualización de Plugins?

Aunque hay varias maneras de solucionarlo, te voy a comentar la más sencilla, la manera en la que no tienes que andar editando código en los ficheros de WordPress.

Instala el plugin “FTP Access“, desde tu instalador del WordPress. Cuando los actives, añade tus datos de acceso FTP para que ya no tengas que volver a introducir estos datos cada vez que quieras instalar o actualizar plugins y temas. Eso sí, ten en cuenta que el problema de seguridad sigue ahí, pero ganas en comodidad. Esta solución te vale si no compartes el ordenador con otras personas.